Twilio - SMS MSISDN support

(Andrew Catchpole) #1

I have been using a PAYG SIM with a regular +4477xxxxxx number which works fine

I have now started using M2M mobile SIM which doesn’t have regular numbers but instead uses MSISDN numbers e.g. MSISDN: +882360008682127

I have tried different combinations but each gets an error from FlowXo

e.g.

  • The ‘To’ number 882360008682127 is not a valid phone number.
  • Permission to send an SMS has not been enabled for the region indicated by the ‘To’ number: +882360008682127.

This may be a flowxo or Twilio issue - any suggestions?

https://www.webopedia.com/TERM/M/MSISDN.html

(Andrew Catchpole) #2

Debug of Twilio shows error code.
Discovered that one needs to add geo-code however Twilio not allowing global code +882 to be added
Ticket raised with Twilio - [Request Opened] Ticket # 2072833

https://www.twilio.com/console/sms/settings/geo-permissions

(Andrew Catchpole) #3

@DanielBeckett @KarenBarker

(Andrew Catchpole) #4

Also worth mentioning is that Twilio now has a new API Explorer which is very rich in features
https://www.twilio.com/console/api-explorer/sms/messages

(Daniel Beckett) #5

The integration wasn’t setup with MSISDN support in mind so officially speaking it’s not really supported at the moment. That’s not to say that it won’t work but it’s not been thoroughly tested. I’d certainly continue troubleshooting with Twilio to see if they can point to any specific reasons as to why it’s not working.

From the Flow XO side I’ll run this by our development team so they can look into making sure the Twilio service can support this and to adjust if necessary.

(Andrew Catchpole) #6

Twilio are now working on a fix to enable the +882 number range required for IoT devices.