New flow stops after the first action


(Peter) #1

I trigger a flow with the Ask-a-question choice.

Basically there is a GotoLabel with a filter on the Ask-a-Question choice set up. So upon the correct answer the bot goes to the Label, which only has one action inside - Trigger-a-Flow with the keyword as below

It all works fine up to here. I even start a new flow:

But here is my problem. Only the first action works (i.e. the first Send-a-Message) (marked with blue) and then I slip to the action from which I started the flow (red arrow). The secong message does not appear and the Label (which can be seen at the bottom of the screenshot) never comes to life. Neither works anything behind the label…

I thought that the flow must end before I get back to the place which called it, but it goes there immediately after the first action of the flow.

I used to test separate flows and all I had in them was one message to indicate that I am inside a new flow, so I did not notice the trouble before.

What am I doing wrong?


(Peter) #2

I have made another sample flow with the same structure and it has the same bug. Can share it with you if that helps.

I even tried to use conditional triggering of flows instead of setting labels to avoid famous GOTO operand, but it doesn’t work either. At least the problem is reproduced.


(Karen Barker) #3

Hi @Peter,

If you can forward the flows to support@flowxo.com then we’ll be able to take a closer look. :slight_smile:


(Peter) #4

Hi @KarenBarker,
Done. Hope you can find the reason.


(Arvell) #5

was this ever solved??


(Karen Barker) #6

Hi @arvell,

I see you’ve emailed the issue in to our support team as well so I’ve responded there. :slight_smile: