Chatbot prevents page scrolling



On our webpage, when you open the chatbot you can’t scroll the webpage. Once you close the chatbot, scrolling is enabled again. I notice that this is the same on Flow XO’s homepage, so I’m guessing this is expected behaviour. It causes a poor user experience, as users may not realise that they have to close the bot before they can scroll.

Is is possible to change this?

1 Like
(Nathan Stults) #2

Hello Eamonccy,

You can do this now with a previously undocumented feature of the Web Messenger via the JavaScript API:

You will need a very small amount of JavaScript code here, but you can use the enableBackgroundScroll option in the ‘setConfig’ method to make the bot behave the way you want. In the future we’ll expose this in the bot config of the user interface, but for the moment the API can be used today.


That’s great, thanks Nathan.

1 Like